ayucatのRuby/Rails日記 (移動中)

.chへ

移行中

Ruby/Rails日記 on ayucat.chへ移行中

 | 

2009-08-24Rails 2.1.2でFastladder(trunk=r32)を動かす

Rails 2.3.3が出てきた2009年夏のFastladderの動かし方 (Ubuntu 9.04)

|  Rails 2.3.3が出てきた2009年夏のFastladderの動かし方 (Ubuntu 9.04) - ayucatのRuby/Rails日記 (移動中) を含むブックマーク はてなブックマーク -  Rails 2.3.3が出てきた2009年夏のFastladderの動かし方 (Ubuntu 9.04) - ayucatのRuby/Rails日記 (移動中)

とある人?にRSSリーダーについて話題をもらったので、Ubuntu 9.04 (Jaunty) で動かすことを試してみた。

  • そのRSSリーダーのソースはレポジトリから最新版 (trunk = r32) をもらってきた。
  • インストールは付属のINSTALL.txtを参考にした。
  • Rubygem,gettext-ruby,libfreeimage3はUbuntuのパッケージを使った。
  • railsやその他のgemgemからインストールした。

で、ハマっていた。

Fastladder側はRails 2.0.2で動くようになっていて、libgettext-ruby (1.91.0-2.1) 側にはRails 2.1以降で動くようなパッチが埋め込んであった。

そのおかげで、Rails 2.0.2のままでは動かなかったみたい。

動かせる、なるべく新しいバージョンを探す

Index: config/environment.rb
===================================================================
--- config/environment.rb	(revision 32)
+++ config/environment.rb	(working copy)
@@ -5,7 +5,7 @@
 # ENV['RAILS_ENV'] ||= 'production'
 
 # Specifies gem version of Rails to use when vendor/rails is not present
-RAILS_GEM_VERSION = '2.0.2' unless defined? RAILS_GEM_VERSION
+RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION
 
 # Bootstrap the Rails environment, frameworks, and default configuration
 require File.join(File.dirname(__FILE__), 'boot')

とした上で、

$ rake rails:update

とした。

Rails 2.3.2ではうまく行かなかったので、ひとまず、これで。

app/controllers/application.rbがエラーになるので、下記を参考に直した。

rails2.1.0に対応させました

でも、ここでconfig/initializers/gettext.rbのいじりは不要。

最新版のlibgettext-rubyを使いたい

Ubuntu ? Errorを眺めてみた。

libgettext-ruby (1.93.0-1) unstable; urgency=low

* New upstream release includes fix for locale issue

(Closes: #490571, #506392, #492907)

* Fix small typo in Depends field (Closes: #487885, #508490);

Thanks for Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com>

* Add Depends to locales package (Closes: #502576)

-- Tatsuki Sugiura <sugi@nemui.org> Wed, 18 Feb 2009 14:05:10 +0900

http://changelogs.ubuntu.com/changelogs/pool/universe/libg/libgettext-ruby/libgettext-ruby_1.93.0-1/changelog

ということなので、ちょっと様子見しようと思った。

Rails 2.1.2でFastladder(trunk=r32)を動かすためのパッチ

|  Rails 2.1.2でFastladder(trunk=r32)を動かすためのパッチ - ayucatのRuby/Rails日記 (移動中) を含むブックマーク はてなブックマーク -  Rails 2.1.2でFastladder(trunk=r32)を動かすためのパッチ - ayucatのRuby/Rails日記 (移動中)

$ svn diff
Index: app/controllers/application.rb
===================================================================
--- app/controllers/application.rb	(revision 32)
+++ app/controllers/application.rb	(working copy)
@@ -1,6 +1,7 @@
 # Filters added to this controller apply to all controllers in the application.
 # Likewise, all the methods added will be available for all controllers.
 
+require 'gettext/rails'
 class ApplicationController < ActionController::Base
   include AuthenticatedSystem
   protect_from_forgery
Index: config/boot.rb
===================================================================
--- config/boot.rb	(revision 32)
+++ config/boot.rb	(working copy)
@@ -24,9 +24,8 @@
       File.exist?("#{RAILS_ROOT}/vendor/rails")
     end
 
-    # FIXME : Ruby 1.9
     def preinitialize
-      load(preinitializer_path) if File.exists?(preinitializer_path)
+      load(preinitializer_path) if File.exist?(preinitializer_path)
     end
 
     def preinitializer_path
@@ -44,6 +43,7 @@
   class VendorBoot < Boot
     def load_initializer
       require "#{RAILS_ROOT}/vendor/rails/railties/lib/initializer"
+      Rails::Initializer.run(:install_gem_spec_stubs)
     end
   end
 
@@ -82,14 +82,14 @@
 
       def load_rubygems
         require 'rubygems'
-
-        unless rubygems_version >= '0.9.4'
-          $stderr.puts %(Rails requires RubyGems >= 0.9.4 (you have #{rubygems_version}). Please `gem update --system` and try again.)
+        min_version = '1.1.1'
+        unless rubygems_version >= min_version
+          $stderr.puts %Q(Rails requires RubyGems >= #{min_version} (you have #{rubygems_version}). Please `gem update --system` and try again.)
           exit 1
         end
 
       rescue LoadError
-        $stderr.puts %(Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: http://rubygems.rubyforge.org)
+        $stderr.puts %Q(Rails requires RubyGems >= #{min_version}. Please install RubyGems and try again: http://rubygems.rubyforge.org)
         exit 1
       end
 
Index: config/environment.rb
===================================================================
--- config/environment.rb	(revision 32)
+++ config/environment.rb	(working copy)
@@ -5,7 +5,7 @@
 # ENV['RAILS_ENV'] ||= 'production'
 
 # Specifies gem version of Rails to use when vendor/rails is not present
-RAILS_GEM_VERSION = '2.0.2' unless defined? RAILS_GEM_VERSION
+RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION
 
 # Bootstrap the Rails environment, frameworks, and default configuration
 require File.join(File.dirname(__FILE__), 'boot')
Index: public/javascripts/effects.js
===================================================================
--- public/javascripts/effects.js	(revision 32)
+++ public/javascripts/effects.js	(working copy)
@@ -1,4 +1,4 @@
-// Copyright (c) 2005-2007 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us)
+// Copyright (c) 2005-2008 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us)
 // Contributors:
 //  Justin Palmer (http://encytemedia.com/)
 //  Mark Pilgrim (http://diveintomark.org/)
Index: public/javascripts/dragdrop.js
===================================================================
--- public/javascripts/dragdrop.js	(revision 32)
+++ public/javascripts/dragdrop.js	(working copy)
@@ -1,4 +1,4 @@
-// Copyright (c) 2005-2007 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us)
+// Copyright (c) 2005-2008 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us)
 //           (c) 2005-2007 Sammi Williams (http://www.oriontransfer.co.nz, sammi@oriontransfer.co.nz)
 // 
 // script.aculo.us is freely distributable under the terms of an MIT-style license.
Index: public/javascripts/controls.js
===================================================================
--- public/javascripts/controls.js	(revision 32)
+++ public/javascripts/controls.js	(working copy)
@@ -1,4 +1,4 @@
-// Copyright (c) 2005-2007 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us)
+// Copyright (c) 2005-2008 Thomas Fuchs (http://script.aculo.us, http://mir.aculo.us)
 //           (c) 2005-2007 Ivan Krstic (http://blogs.law.harvard.edu/ivan)
 //           (c) 2005-2007 Jon Tirsen (http://www.tirsen.com)
 // Contributors:

KaednKaedn 2011/05/04 16:31 Ppl like you get all the brains. I just get to say thanks for he awnser.

fvdgxzjrujfvdgxzjruj 2011/05/05 11:15 Od3xKu <a href="http://iexzrpeaxnnv.com/">iexzrpeaxnnv</a>

stkwvsoqvlstkwvsoqvl 2011/05/06 10:28 PhR64j , [url=http://zhtpriauytiz.com/]zhtpriauytiz[/url], [link=http://vjcmlklblycd.com/]vjcmlklblycd[/link], http://gyxvzsriamuc.com/

czkmoexwczkmoexw 2011/05/07 13:21 AUMHrT <a href="http://tsnhjhxhdbhz.com/">tsnhjhxhdbhz</a>

axzawdcuxaxzawdcux 2011/05/08 13:43 F4J6WA , [url=http://mvtoyxgjagfr.com/]mvtoyxgjagfr[/url], [link=http://nzoohfgasgwt.com/]nzoohfgasgwt[/link], http://ebxxblssqzhl.com/

ゲスト



トラックバック - http://rubyist.g.hatena.ne.jp/ayucat_on_tabelog/20090824
 |