Hatena::Grouprubyist

Rubyを勉強しようと思ってはじめた日記

2008-09-27

はてなダイアリーのAtomPubを試してみました

| 18:10 | はてなダイアリーのAtomPubを試してみました - Rubyを勉強しようと思ってはじめた日記 を含むブックマーク はてなブックマーク - はてなダイアリーのAtomPubを試してみました - Rubyを勉強しようと思ってはじめた日記 はてなダイアリーのAtomPubを試してみました - Rubyを勉強しようと思ってはじめた日記 のブックマークコメント

はてなダイアリーのAtomPubを試してみました

require 'rubygems'
require 'atomutil'

module Atompub
  class HatenaClient < Client
    def publish_entry(uri)
      @hatena_publish = true
      update_resource(uri, ' ', Atom::MediaType::ENTRY.to_s)
    ensure
      @hatena_publish = false
    end 

    private
    def set_common_info(req)
      req['X-Hatena-Publish'] = 1 if @hatena_publish
      super(req)
    end 
  end 
end

auth    = Atompub::Auth::Wsse.new :username => 'd4-1977', :password => 'hogehoge'
client  = Atompub::HatenaClient.new :auth => auth
service = client.get_service 'http://d.hatena.ne.jp/d4-1977/atom'
collection_uri = service.workspace.collections[1].href

entry = Atom::Entry.new(
  :title => 'My Entry Title',
  :updated => Time.now
)

entry.content = <<EOF
エントリー本文だよ
EOF

puts client.create_entry collection_uri, entry

はてなダイアリーのAtomPubを試そうとしてみました

| 15:42 | はてなダイアリーのAtomPubを試そうとしてみました - Rubyを勉強しようと思ってはじめた日記 を含むブックマーク はてなブックマーク - はてなダイアリーのAtomPubを試そうとしてみました - Rubyを勉強しようと思ってはじめた日記 はてなダイアリーのAtomPubを試そうとしてみました - Rubyを勉強しようと思ってはじめた日記 のブックマークコメント

はてなダイアリーのAtomPubを試そうとしてみました。

ruby HanteaClient.rb 
/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:578:in `report_activate_error': Could not find RubyGem hoe (>= 1.7.0) (Gem::LoadError)

うん?hoeのバージョン?hoe?そこで、gemでhoeをインストール

gem install --remote hoe

これで問題なし。hoeっていうのがあるんですね。

gemを1.0.1から1.2.0にした

| 15:33 | gemを1.0.1から1.2.0にした - Rubyを勉強しようと思ってはじめた日記 を含むブックマーク はてなブックマーク - gemを1.0.1から1.2.0にした - Rubyを勉強しようと思ってはじめた日記 gemを1.0.1から1.2.0にした - Rubyを勉強しようと思ってはじめた日記 のブックマークコメント

gemを使うと、VMwareのCPU使用率が非常に高くなりました。

それが、原因で、VAIOの発熱がひどいことになっていました。

さくらインターネットのサーバで、1.2.0を利用してみると、すんなり動くので、バージョンアップをすることに。手順はインストールと同じ。

cd ./local/src
wget http://rubyforge.org/frs/download.php/38646/rubygems-1.2.0.tgz
tar xfvz rubygems-1.2.0.tgz
cd rubygems-1.2.0
ruby setup.rb config
ruby setup.rb setup
ruby setup.rb install

そうしたら、問題なかった!

バージョンの違いで、こんなに違うのか。

ゲスト



トラックバック - http://rubyist.g.hatena.ne.jp/d4-1977/20080927
カレンダー
2007 | 12 |
2008 | 01 | 02 | 03 | 04 | 05 | 06 | 07 | 09 | 10 | 11 | 12 |
2009 | 06 | 08 |