Hatena::Grouprubyist

たばさの RSSフィード

03/03(月) 2008

rails

| rails - たばさの を含むブックマーク はてなブックマーク - rails - たばさの

googleで「rails インストール」検索して

http://tobysoft.net/wiki/index.php?Ruby%2FRuby%20on%20Rails%2F%A5%A4%A5%F3%A5%B9%A5%C8%A1%BC%A5%EB%20for%20windows

なんか簡単そう。

>gem install rails -y

>rails test

>ruby test/script/server
Rails requires RubyGems >= 0.9.4 (you have 0.9.2). Please `gem update --system`
and try again.

>gem -v
0.9.2

>gem update --system
Updating RubyGems...
(...略...)
RubyGems system software updated

>gem -v
1.0.1

>ruby test/script/server
=> Booting WEBrick...
=> Rails application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-03-04 01:00:45] INFO  WEBrick 1.3.1
[2008-03-04 01:00:45] INFO  ruby 1.8.6 (2007-09-24) [i386-mswin32]
[2008-03-04 01:00:48] INFO  WEBrick::HTTPServer#start: pid=...
(...略...)

gem updateを除けば本当に3行だった。何が起きてるのかはわからないけども。

しかし最初長い間は無言でジージーとハードディスクに書き込みはじめてあせった。

半日かかるとは思わず。

ついでに1.9とjruby


>ruby1.9.0 test/script/server
.../test/config/boot.rb:86:in `load_rubygems': undefined method `>=' for
nil:NilClass (NoMethodError)
...(略)

>jruby test/script/server
Missing the Rails 2.0.2 gem. Please `gem install -v=2.0.2 rails`, update your RA
ILS_GEM_VERSION setting in config/environment.rb for the Rails version you do ha
ve installed, or comment out RAILS_GEM_VERSION to use the latest version install
ed.

>rails -v
Rails 2.0.2

ダメなようです。とりあえずはこんなところで。

トラックバック - http://rubyist.g.hatena.ne.jp/hatecha/20080303
カレンダー
<< 2008/03 >>
1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31
archive Error : RSSが取得できませんでした。