Hatena::Grouprubyist

たばさの RSSフィード

10/20(火) 2009

vmware on ubuntu9.04

| vmware on ubuntu9.04 - たばさの を含むブックマーク はてなブックマーク - vmware on ubuntu9.04 - たばさの

debがないがtar.gzを

tar zxvf ...tar.gz

でinstall.plとやってみた。某所でコンパイルでエラーになるらしいとあったが目立ったエラーもなく終了。でもだめっぽい。おしい?

ubuntu@ubuntu:~$ sudo /etc/init.d/vmware start
Starting VMware services:
   Virtual machine monitor                                            failed
   Virtual machine communication interface                             done
   Virtual ethernet                                                   failed
   Bridged networking on /dev/vmnet0                                   done
   Host-only networking on /dev/vmnet1 (background)                    done
   DHCP server on /dev/vmnet1                                          done
   Host-only networking on /dev/vmnet8 (background)                    done
   DHCP server on /dev/vmnet8                                          done
   NAT service on /dev/vmnet8                                         failed
ubuntu@ubuntu:~$ vmware
@@PRODUCT_NAME@@ is installed, but it has not been (correctly) configured
for the running kernel. To (re-)configure it, invoke the
following command: /usr/bin/vmware-config.pl.

ubuntu@ubuntu:~$ sudo /etc/init.d/vmware status
Bridged networking on /dev/vmnet0 is running
Host network detection is not running
Host-only networking on /dev/vmnet1 is running
DHCP server on /dev/vmnet1 is running
Host-only networking on /dev/vmnet8 is running
DHCP server on /dev/vmnet8 is running
NAT networking on /dev/vmnet8 is not running
Module vmmon loaded
Module vmnet loaded
ubuntu@ubuntu:~$ 

あきらめてwindowsにしとくか。

debianのひとはまめだからだれかdeb作ってくれてるよみたいな書き込みがあっておもしろい。


そのまえにmake-vmpkgも検索してバージョンチェックスキップなどのオプションで出来そうで途中でエラーになった。



f:id:hatecha:20091020164818p:image

f:id:hatecha:20091020164819p:image

できた、ubuntu on vmware on ubuntu。あ、ゲストはremastersysでカスタマイズしたubuntu-ruby入り。

再インストール、ブラウザやos再起動など繰り返し。そういえば一度目もログイン画面は見た。

livecdなのでrootがパスワードブランクで弾かれたので今回は設定してログインできた。あとはisoの置き場所がインストールの時に指定した場所のみなどがひっかかり。コンパイルもabortで終了する時もあった。初回はそんなのなかったのに。キーは残っているのか最初の一回いれただけだ。あとは問題はぎりぎりなディスク容量か。



やったことまとめ。

・パッケージマネージャでvmware関係をインストール、これも関係ないかな

本家で登録、メールでキーが届く。vmware server tar.gzをダウンロード、展開、なかにあるinstall.pl実行。登録時のパスワードはなんのパスと思ったら次回同じダウンロードページに入るんだな。ないと入れなそう。

・sudo vmware

sudoはいるかな.これでserverが起動し、firefoxが立ち上がりlogin. server 立ち上げのユーザーでログインかな。

web画面でvirtual machine設定後再生ボタンでスタート、firefoxのプラグインが必要でローカルからインストールなので許可をしてインストール、firefox再起動でゲスト起動。マシンの設定時とおなじoscdisoが必要。サブ画面でゲストのデスクトップ、f11でも全画面にはなってない。windowsでplayerだとホストと見分けがつかないくらいなんだけど。

なにかがひとつだけとあった気がするなんだっけ。

トラックバック - http://rubyist.g.hatena.ne.jp/hatecha/20091020
カレンダー
<< 2009/10 >>
1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
archive Error : RSSが取得できませんでした。