Hatena::Grouprubyist

たばさの RSSフィード

03/04(木) 2010

mechanize1.0.0 warning

| 17:22 | mechanize1.0.0 warning - たばさの を含むブックマーク はてなブックマーク - mechanize1.0.0 warning - たばさの

警告でるようになったんですねぇ



 >ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]

 >ruby -e'require"mechanize";puts WWW::Mechanize::VERSION'
!!!!! DEPRECATION NOTICE !!!!!
The WWW constant is deprecated, please switch to the new top-level Mechanize
constant.  WWW will be removed in Mechanize version 2.0

You've referenced the WWW constant from -e:1, please
switch the "WWW" to "Mechanize".  Thanks!

Sincerely,

  Pew Pew Pew

1.0.0

 >ruby -e'require"mechanize";puts Mechanize::VERSION'
1.0.0

 >ruby -W0 -e'require"mechanize";puts WWW::Mechanize::VERSION'
1.0.0

 >

Pew Pew Pewってなにふざけてるの?



 >ruby -rmechanize -e'puts"hoge"'
ruby: no such file to load -- mechanize (LoadError)

 >ruby -rrubygems -rmechanize -e'puts"hoge"'
ruby: no such file to load -- mechanize (LoadError)

 >ruby -e'require"mechanize";puts"hoge"'
hoge

ん?


ubuntuのほうではHpricotのエラーが出る(ということはnokogiriを使ってない)のでgem install mechanize(ver.1.0.0), nokogiriとやってもlibwww-mechanize-ruby(ver.0.8)のほうをみてしまうようで動かず、相変わらずHpricotを見る。

gem関連の環境変数設定とgem methodでバージョン指定すると動いた。`ruby file.rb`などと呼び出してる部分はどうしたらいいかな。全部-W0するのも面倒というかなんというか。

トラックバック - http://rubyist.g.hatena.ne.jp/hatecha/20100304
カレンダー
<< 2010/03 >>
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31
archive Error : RSSが取得できませんでした。