バリケンのRuby日記 RSSフィード

2007-10-10

[][] Ruby on Rails 1.2.4  Ruby on Rails 1.2.4 - バリケンのRuby日記 を含むブックマーク はてなブックマーク -  Ruby on Rails 1.2.4 - バリケンのRuby日記  Ruby on Rails 1.2.4 - バリケンのRuby日記 のブックマークコメント

遅まきながら、Ruby on Railsバージョンを1.2.3から1.2.4に上げてみたよ。Railsバージョンが上がるのは久しぶりだねえ。そういえば、以前書いたRuby on Railsのインストール方法のエントリも1.2.3だったね。

アップグレードは、いつものとおりコマンド一発

$ gem update rails

でできるよ。これでうまくいかない人は、activesupport-1.4.3.gemactiverecord-1.15.4.gemactionpack-1.13.4.gemactionwebservice-1.2.4.gemactionmailer-1.3.4.gemrails-1.2.4.gemを直接ダウンロードして

$ gem install activesupport-1.4.3.gem
$ gem install activerecord-1.15.4.gem
$ gem install actionpack-1.13.4.gem
$ gem install actionwebservice-1.2.4.gem
$ gem install actionmailer-1.3.4.gem
$ gem install rails-1.2.4.gem

でもアップグレードできるよ。

インストール済みの前のバージョン(1.2.3)が完全にいらないという人は、1.2.4をインストール後に

$ gem clean activesupport activerecord actionpack actionwebservice actionmailer rails

で1.2.3を削除できるよ。

gemコマンドの詳細については、るびまのRubyGemsに関する記事を参考にしてね。

いまのところ、手元にいくつかあるRails 1.2.3用のRailsアプリRails 1.2.4でも問題なく(config/environment.rbに書かれたバージョンの修正程度で)動くみたい。

あ、もちろんvendor/rails以下にRailsが丸ごと入っているようなアプリ(redMineとか)なら、インストールされているRailsバージョンに影響されることなくvendor/rails以下のRailsを使うみたいだから、特に何もしなくてもそのまま使い続けられるよ。

トラックバック - http://rubyist.g.hatena.ne.jp/muscovyduck/20071010