バリケンのRuby日記 RSSフィード

2007-10-20

[][] Beast  Beast - バリケンのRuby日記 を含むブックマーク はてなブックマーク -  Beast - バリケンのRuby日記  Beast - バリケンのRuby日記 のブックマークコメント

Railsで実装された掲示板WebアプリBeast」を試してみたよ。

余談だけど、Beastのサイト自体がBeastで動いているみたいだね。

いまのところインストール用のアーカイブは用意されていないみたいだから、直接Subversionリポジトリからexportして入手するよ。ここではバージョン1.0を入手してみたよ。

$ svn export http://svn.techno-weenie.net/projects/beast/tags/rel-1.0 beast-1.0

あとはREADMEを見ればインストール方法が書いてあるけど、いちおうメモしておくよ。

$ cd beast-1.0
$ cp config/database.example.yml config/database.yml
$ vi config/database.yml
$ rake db:schema:load

ここで「Warning: require_gem is obsolete. Use gem instead」と表示されるようなら、「rake rails:update:configs」でconfigファイルをアップデートするよ。

あとは、起動するだけだよ。

$ ruby script/server

ブラウザhttp://localhost:3000/アクセスしてね。

ログインしないとスレ立てや書き込みができないから、まずは右上の「Signup」でアカウントを作ってから、ログインしてね。

ログインすると右側に「Create new forum」というリンクが出てくるから、それをクリックするとスレ立てができるよ。

あとは立てたスレッドに書き込みをしたりレスを付けたり、いろいろと試してみてね。

トラックバック - http://rubyist.g.hatena.ne.jp/muscovyduck/20071020