Hatena::Grouprubyist

うんたらかんたらRuby RSSフィード

2009-01-09rails2.2からmysqlのドライバが標準添付じゃなくなってる

rails2.2からmysqlのドライバが標準添付じゃなくなってる

| rails2.2からmysqlのドライバが標準添付じゃなくなってる - うんたらかんたらRuby を含むブックマーク はてなブックマーク - rails2.2からmysqlのドライバが標準添付じゃなくなってる - うんたらかんたらRuby

redmineを入れてみようかとインストールしてmigrateしたらこけた。

wget http://rubyforge.org/frs/download.php/49319/redmine-0.8.0.tar.gz
tar zxvf redmine-0.8.0.tar.gz
cd remine-0.8.0
cp config/database.yml.example config/database.yml

mysql> create database redmine_development;

rake db:migrate

エラー内容。

== 5 IssueStartDate: migrating ================================================
-- add_column(:issues, :start_date, :date)
rake aborted!
SQLite3::SQLException: near "ADD": syntax error: ALTER TABLE "issues" ADD "start_date" date

(See full trace by running task with --trace)

Riding Rails: Using SQLite3 with Rails

どうやら、gemでsqlite3-rubyをインストールした後

sqlite3をmac portsで再インストールしたらうまくいったよ。

ってなことが書いてあるので

やってみた。

$ sudo gem install sqlite3-ruby 
Building native extensions.  This could take a while...
Successfully installed sqlite3-ruby-1.2.4
1 gem installed
Installing ri documentation for sqlite3-ruby-1.2.4...
Installing RDoc documentation for sqlite3-ruby-1.2.4...

$ sudo port -f uninstall sqlite3 @3.6.3_0
--->  Unable to uninstall sqlite3 3.6.3_0, the following ports depend on it:
--->    apr-util
Warning: Uninstall forced.  Proceeding despite dependencies.
--->  Deactivating sqlite3 3.6.3_0
--->  Uninstalling sqlite3 3.6.3_0

$ sudo port install sqlite3
--->  Fetching sqlite3
--->  Verifying checksum(s) for sqlite3
--->  Extracting sqlite3
--->  Configuring sqlite3
--->  Building sqlite3 with target all
--->  Staging sqlite3 into destroot
--->  Installing sqlite3 3.6.3_0
--->  Activating sqlite3 3.6.3_0
--->  Cleaning sqlite3

勢いでsqlite3入れ直してしまった。

sqlite-rubyが古いだけで

sqlite3は入れ直す必要がなかったかも。(未検証)

トラックバック - http://rubyist.g.hatena.ne.jp/rochefort/20090109