Hatena::Grouprubyist

うんたらかんたらRuby RSSフィード

2010-05-31cucumber textmateバンドル

cucumber textmateバンドル

| cucumber textmateバンドル - うんたらかんたらRuby を含むブックマーク はてなブックマーク - cucumber textmateバンドル - うんたらかんたらRuby

メモ。


Library/Application Support/TextMate/Bundles

に突っ込んで、バンドルReloadするだけ。

bmabey's cucumber-tmbundle at master - GitHub


シナリオのコピペ(移動)時にインデントが下がってしまうのが難点。

トラックバック - http://rubyist.g.hatena.ne.jp/rochefort/20100531

2010-03-24textmateのcheat sheet

textmateのcheat sheet

| textmateのcheat sheet - うんたらかんたらRuby を含むブックマーク はてなブックマーク - textmateのcheat sheet - うんたらかんたらRuby

TextMate Cheat Sheet

f:id:rochefort:20100324230739p:image


自分がよく使うやつを纏めてみた。

こちらを元に作成。

tab triggerは山ほどあるけど、ほとんど頭に入ってない。

適当にtab押すと結構あたる。


2010/03/28追記

css sprite使って文字化け治したかったけど

floatカオス過ぎてあきらめた。

とりあえず画像に置き換えたのでwindowsでも見れるようにはなったはず(未確認)。

機種依存文字、CSS、画像編集難しい。


参考

Mike Clark's Weblog

rochefortrochefort2010/03/25 23:08文字化けしてますね。今日は酔っ払ってどうにもこうにもな感じなので、後で直します。

トラックバック - http://rubyist.g.hatena.ne.jp/rochefort/20100324

2009-10-01rascutをtextmateで

rascutをtextmateで

| rascutをtextmateで - うんたらかんたらRuby を含むブックマーク はてなブックマーク - rascutをtextmateで - うんたらかんたらRuby

↓をやってみた。

TextMate+Flex 3 SDK+rascutで作るMac OS XのActionScript開発環境 - page4 - builder by ZDNet Japan


ASやりたいけど、Flex Builderは高いので

windowsみたいにFlashDevelopみたいなのを探していて出会った。


Rascut.tmbundleが動かない。

困っていたところコメントを見ると

Rascut.tmbundle/Templates/Project.tmTemplate/_create_rascut_project.sh

が644なため、シェルスクリプトが動かないようです。

chmod +x _create_rascut_project.sh と実行ビットを立てると動くようになります。

とあった。ありがとう!


Start Rascutできない

最後にtextmateから実行するところでもこけた。

/opt/local/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- appscript (LoadError) from /opt/local/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:31:in `require' from /tmp/ruby-amp-41138.rb:2


なるほど、appscriptがrequireできないと。

gem search -r appscript すると出てきたのでインストール。

sudo gem install rb-appscript


これで解決。

トラックバック - http://rubyist.g.hatena.ne.jp/rochefort/20091001

2009-09-29textmate GetBundle

textmate GetBundle

| textmate GetBundle - うんたらかんたらRuby を含むブックマーク はてなブックマーク - textmate GetBundle - うんたらかんたらRuby

rubyあんま関係ないけど。

TextMateをProcessingのエディタ代わりにする | warikiru


bundleのパッケージ管理ツール。

TextMate Manual » Bundles

マニュアル見るとsvnクライアントが必要な模様。


.bashrcとか.bash_profileとかに

export LC_TYPE=en_US.UTF-8

mkdir -p /Library/Application\ Support/TextMate/Bundles
cd /Library/Application\ Support/TextMate/Bundles
svn co http://svn.textmate.org/trunk/Bundles/Haskell.tmbundle

再起動後

Bundles > Bundle Editor > Show Bundle Editor > GetBundle > Install BundleのBASE_URL部分を以下に変更。

BASE_URL=http://svn.textmate.org/trunk/


補足

↓でbundleのupdateができるらしい。

cd /Library/Application\ Support/TextMate/Bundles
svn up *.tmbundle
トラックバック - http://rubyist.g.hatena.ne.jp/rochefort/20090929

2009-09-28railscastsのtextmate用theme

railscastsのtextmate用theme

| railscastsのtextmate用theme - うんたらかんたらRuby を含むブックマーク はてなブックマーク - railscastsのtextmate用theme - うんたらかんたらRuby

Railscasts - About Railscasts


Railscasts.tmThemeDownloadを選択

f:id:rochefort:20090928223616p:image


ダウンロードしたファイルをダブルクリックすると

~/Library/Application\ Support/TextMate/Themes/ 下にコピーされる。


こんな感じ。

f:id:rochefort:20090928223618p:image

トラックバック - http://rubyist.g.hatena.ne.jp/rochefort/20090928